Ubuntu’da “Package dependencies cannot be resolved” hatası

Merhaba, bu yazımızda ubuntu’da ek paketler kurmak isterken karşımıza çıkan “Package dependencies cannot be resolved” hatası ile ilgili çözüme değineceğim.

Package dependencies cannot be resolved hatası genellikle bazı paketlerde oluşan bir hatadan dolayı alınmaktadır. Bu durumu düzeltmek için terminale aşağıda ki kodları yazın;

sudo apt-get update
sudo apt-get -f install
sudo dpkg --configure --pending
sudo dpkg --configure -a

İlgili hatanın oluşma sebebine gelecek olursak, daha önceden yaptığınız bir işlemden dolayı (depo ekleme vs) kaynak kodlarında oynama yapılmasından gerçekleşmektedir.

Eğer ilgili hata hâlâ geçmez ise aşağıda ki kodları deneyin;

sudo apt-get update
sudo apt-get upgrade

Bu da çözüm olmazsa aşağıda ki komutların hepsini kopyala+yapıştır ile çalıştırın;

sudo apt-get install -f &&
sudo apt-get clean &&
sudo apt-get autoclean &&
sudo apt-get autoremove &&
sudo add-apt-repository ppa:ubuntu-wine/ppa &&
sudo apt-get update &&
sudo apt-get upgrade &&
sudo apt-get install wine1.5

 

Bir Cevap Yazın